Let's Encrypt SSL Certificate not working

Discussion in 'Magento Support' started by pelparc, Aug 8, 2017.

  1. pelparc

    pelparc UKBF Regular Free Member

    242 27
    Hope someone can help.
    I will soon have to reinstall my ssl certificate for my main shop so i decided i would try the free Let's Encrypt SSL Certificate on a shop that is almost obsolete 1.9 version site first. I installed the Let's Encrypt SSL Certificate via my hosts plesk interface (all seemed to simple. Just a couple of clicks). changed the configuration web setting for secure to https. But when i go to the checkout pages i am warned via chrome that it is not secure. Am i missing something in the configuration?
     
    Posted: Aug 8, 2017 By: pelparc Member since: Apr 10, 2017
    #1
  2. zigojacko

    zigojacko I say it how it is Full Member - Verified Business

    3,531 1,120
    It is possible that some static content may be served via a non-secure (http) URL on your cart page. What is the URL of your store please?
     
    Posted: Aug 8, 2017 By: zigojacko Member since: Dec 7, 2009
    #2
  3. pelparc

    pelparc UKBF Regular Free Member

    242 27
    Thanks zigojacko.
    I have PM'd you the URL as i don't want the URL to be advertised publicly in is current state.
    Thanks again
     
    Posted: Aug 8, 2017 By: pelparc Member since: Apr 10, 2017
    #3
  4. zigojacko

    zigojacko I say it how it is Full Member - Verified Business

    3,531 1,120
    Thanks, got your PM.

    I can confirm that the SSL certificate is not installed correctly on the server.

    In Plesk, have you assigned the SSL certificate under Hosting Settings to the domain?
     
    Posted: Aug 8, 2017 By: zigojacko Member since: Dec 7, 2009
    #4
  5. NuBlue

    NuBlue UKBF Ace Full Member

    1,167 236
    Let's Encrypt have a Plesk extension. If you've installed it by going to the domain and using the Let's Encrypt option then it should be installed OK. Did you tick the enable on www. option as well?
     
    Posted: Aug 8, 2017 By: NuBlue Member since: Oct 19, 2005
    #5
  6. pelparc

    pelparc UKBF Regular Free Member

    242 27
    Thanks both,
    trying to check, however i cant seem to connect to plesk at the moment will try later.
     
    Posted: Aug 8, 2017 By: pelparc Member since: Apr 10, 2017
    #6
  7. webhostuk

    webhostuk UKBF Ace Full Member - Verified Business

    1,342 164
    If all is well, you can even give a try by reinstalling it, most of the times some missing things get sorted while re-install.
     
    Posted: Aug 9, 2017 By: webhostuk Member since: Jul 26, 2009
    #7
  8. pelparc

    pelparc UKBF Regular Free Member

    242 27
    Host updated Plesk version... However i missed the tick box for the "www" version. Renewed again and now all ok thanks all.

    a couple more questions my main site already has a paid for certificate that runs out in a couple of weeks. I want to use a lets's encrypt cert, if i install this now how will this effect my site if it already has an existing none let's encrypt cert? Can both run side by side so when the old one runs out the new one will already be in place?

    I looks like the let's encrypt scheme automatically renews does this mean i no longer have to worry about installing the certificate each year?

    Thanks again for your help
     
    Posted: Aug 9, 2017 By: pelparc Member since: Apr 10, 2017
    #8
  9. NuBlue

    NuBlue UKBF Ace Full Member

    1,167 236
    On Plesk, installing the LE SSL should change the hosting setting so it's used straight away and the other SSL will just expire when it expires. You can check, and change, the SSL being used if you go into the control panel, then the domain, Hosting Settings and scroll down to Security.

    LE SSLs auto-renew every 3 months as long as DNS points to the server.
     
    Posted: Aug 9, 2017 By: NuBlue Member since: Oct 19, 2005
    #9
  10. pelparc

    pelparc UKBF Regular Free Member

    242 27
    Thank you all. Worked perfectly and so easy to install in the end.
     
    Posted: Aug 10, 2017 By: pelparc Member since: Apr 10, 2017
    #10