Here we go again - site email system failure

Discussion in 'Wordpress Support' started by Davek0974, Dec 6, 2019.

  1. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    There is on the live site and that not working either.

    I have tech on it again but they are struggling because the failures do not show in the Track-Delivery log of cPanel - its like they do not hit my server at all.

    It works ok for me but not for anyone else
     
    Posted: Dec 8, 2019 By: Davek0974 Member since: Mar 7, 2008
    #21
  2. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    the error pops up where it should say "Message sent" but just goes to a blank page and says there is a critical error with the system

    You say it works ok but i have not received any message from the site.
     
    Posted: Dec 8, 2019 By: Davek0974 Member since: Mar 7, 2008
    #22
  3. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Any ideas guys?

    the host's tech guy can't do anything because the fault is occurring before it reaches the server/email system so there are no error logs etc.

    I just need to be able to have a working Contact-Us form that can send with SMTP because WP-Mail is flaky with some email providers.
     
    Posted: Dec 9, 2019 By: Davek0974 Member since: Mar 7, 2008
    #23
  4. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    I've just sent a message from the test form and didn't see an error message.
    I've done the same from you contact page (twice) and didn't see an error message.

    Do you want others on UKBF to do the same?
     
    Posted: Dec 9, 2019 By: fisicx Member since: Sep 12, 2006
    #24
  5. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yes, if anyone has a minute, please try it...

    http://testsite.davekearley.co.uk/contact-us/

    Any errors, please post here.

    Thanks
     
    Posted: Dec 9, 2019 By: Davek0974 Member since: Mar 7, 2008
    #25
  6. ffox

    ffox UKBF Regular Free Member

    1,289 232
    Posted: Dec 9, 2019 By: ffox Member since: Mar 11, 2004
    #26
  7. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Message received, thanks.

    Anyone else fancy a go?
     
    Posted: Dec 9, 2019 By: Davek0974 Member since: Mar 7, 2008
    #27
  8. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Anyone have a gMail, yahoo or hotmail account they can try sending on??

    Still not getting anything from these addresses ;)
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #28
  9. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Do you have SPF and DKIM enabled on your hosting?

    Many webmail services get uppity if you don’t have the necessary security controls enabled.
     
    Posted: Dec 10, 2019 By: fisicx Member since: Sep 12, 2006
    #29
  10. UKSBD

    UKSBD Not a real duck Staff Member

    9,964 1,942
    it doesn't like it if you put an @gmail.com email address in.

    Use a completely fake domain works.

    Has @gmail.com been added to a filter?

    Do you receive direct emails from @gmail.com email addresses?
     
    Posted: Dec 10, 2019 By: UKSBD Member since: Dec 30, 2005
    #30
  11. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yes i have found the actual sender address is really odd, you can use any name at my server and it works, use a gmail and it fails, yahoo fails, hotmail too.

    yes i get gmail direct ok plus all the others.
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #31
  12. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    I will check, if i cant find out i'll open a ticket and ask.
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #32
  13. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yes both enabled.
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #33
  14. ffox

    ffox UKBF Regular Free Member

    1,289 232
    Posted: Dec 10, 2019 By: ffox Member since: Mar 11, 2004
    #34
  15. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yep, thats the error message.

    Still no idea how to fix though. :(
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #35
  16. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Enable wp_debug and it will report the error.

    https://codex.wordpress.org/WP_DEBUG

    There are over 6000 people using the plugin and you appear to be the only one having a problem! If it were a plugin issue then I'd have a lot more complaints.
     
    Posted: Dec 10, 2019 By: fisicx Member since: Sep 12, 2006
    #36
  17. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    I'm not pointing fingers Fisicx ;) I'm just a poor user stuck with an issue. I think NickGrogan on page 1 also has same problem.

    I'll play with WP_Debug.
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #37
  18. NickGrogan

    NickGrogan UKBF Ace Full Member

    2,451 583
    Mine works, and records the data, but it is erratic when it comes to sending emails.

    I setup using amazon ses for SMTP, it says it works, but crashes in use.

    What host are you with @Davek0974
     
    Posted: Dec 10, 2019 By: NickGrogan Member since: Nov 15, 2012
    #38
  19. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Indeed. But until I know the what the error is I can't fix it!
     
    Posted: Dec 10, 2019 By: fisicx Member since: Sep 12, 2006
    #39
  20. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    OK, so maybe i'm dumb or something but i have all three debug options turned on and see nothing, no messages, no logs etc.

    I did find a file "error.log" in the WP base folder, the last entry was this

    [10-Dec-2019 17:49:44 UTC] PHP Warning: Use of undefined constant basedir - assumed 'basedir' (this will throw an Error in a future version of PHP) in /home/ddmetalp/testsite.davekearley.co.uk/wp-content/plugins/quick-contact-form/quick-contact-form.php on line 636
    [10-Dec-2019 17:49:44 UTC] PHP Fatal error: Uncaught phpmailerException: SMTP Error: data not accepted. in /home/ddmetalp/testsite.davekearley.co.uk/wp-includes/class-phpmailer.php:1587
    Stack trace:
    #0 /home/ddmetalp/testsite.davekearley.co.uk/wp-includes/class-phpmailer.php(1340): PHPMailer->smtpSend('Date: Tue, 10 D...', 'This is a multi...')
    #1 /home/ddmetalp/testsite.davekearley.co.uk/wp-includes/class-phpmailer.php(1215): PHPMailer->postSend()
    #2 /home/ddmetalp/testsite.davekearley.co.uk/wp-content/plugins/quick-contact-form/quick-contact-form.php(708): PHPMailer->send()
    #3 /home/ddmetalp/testsite.davekearley.co.uk/wp-content/plugins/quick-contact-form/quick-contact-form.php(890): qcf_process_form(Array, 'ContactUs')
    #4 /home/ddmetalp/testsite.davekearley.co.uk/wp-content/plugins/quick-contact-form/quick-contact-form.php(1056): qcf_loop('ContactUs')
    #5 /home/ddmetalp/testsite.davekearley.co.uk/wp-includes/shortcodes.php(325): qcf_start(Array, '', 'qcf')
    #6 [internal function]: do_shortcode_tag(Array)
    #7 /home/ddmetalp/testsite.davekearley.co.uk/wp in /home/ddmetalp/testsite.davekearley.co.uk/wp-includes/class-phpmailer.php on line 1587


    Means nothing at all to me though.
     
    Posted: Dec 10, 2019 By: Davek0974 Member since: Mar 7, 2008
    #40