Here we go again - site email system failure

Discussion in 'Wordpress Support' started by Davek0974, Dec 6, 2019.

  1. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Hi all,

    I'm using WP Mail Bank (free version) for my site, the contact form is from Fisicx on here.

    Have just had an irate customer contact me asking for me to reply - i would never not-reply to a possible customer so looked into the system.

    I see I have lost 5 possible customers in the last couple of weeks simply by not replying to a message i never knew i had, here's what happens...

    Customer uses the "Contact Us" form on the site, WPMail sends the customer the usual "we will get back asap" message ok but then fails to forward the enquiry to me - it shows as customer email "Sent OK" my email "Not Sent"

    Clearly this is a serious problem and i cant even check how long its been going on as the plugin only stores 25 odd emails. I tried upgrading to the Pro version but the page just fails to load each time so thats a non-starter. With the Pro version i could actually see the email content but not on the free version.

    I have tried it myself on the website and it worked ok, I tried the test email option in the plugin and that worked too.

    I am at a loss as to how to fix this issue but its clearly a serious fault and most likely costing orders and damaging any reputation i might have.

    Any ideas?????

    Thanks
     
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #1
  2. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Looks like the author - Tech Banker may have gone? Nothing will load on their site and the few members they have on their Facebook page don't sound very happy ;)

    Maybe need to change plugin (again) ???
     
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #2
  3. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Why are you even using this plugin? The contact form stores all the messages in your dashboard. No need for anything else.
     
    Posted: Dec 6, 2019 By: fisicx Member since: Sep 12, 2006
    #3
  4. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    I didn't think the QCF actually sent emails? I need to use SMTP as i had big issues before with failure to talk to Gmail users.

    Thanks for reminding about the log, very useful. The reason i don't use it is because the only time I'm in the website is when stuff needs doing - maintenance, new products, sending order-complex messages etc, I'm not in there all the time so a working email system is vital.
     
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #4
  5. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    QCF has an SMTP option
     
    Posted: Dec 6, 2019 By: fisicx Member since: Sep 12, 2006
    #5
  6. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yes, just looked and it was all filled in and a test worked, for some reason the "Use SMTP" option had reverted to "Use WP Mail" no idea why or when.

    I will look further as to why I have that email plugin installed, it seems to be surplus??
     
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #6
  7. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    OK, on my test-site, I have switched the QCF form back to SMTP and then went into SMTP test/setup.

    The email passes fine in the test/setup page but when i drop back to the QCF plugin message test page and do a test email it fails with a "Critical error" message

    On the website it gives the same failure.

    Any ideas Fisicx?
     
    Last edited: Dec 6, 2019
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #7
  8. NickGrogan

    NickGrogan UKBF Ace Full Member

    2,451 583
    I get the same errors, no idea why.
     
    Posted: Dec 6, 2019 By: NickGrogan Member since: Nov 15, 2012
    #8
  9. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Thanks, thats a help i think, at least its not an isolated issue. I have sent a direct support request to Fisicx along with an error log entry from WooCommerce system status tabs.

    The fact that it passes SMTP settings ok but then fails when called from the plugin seems to support a plugin bug or error i think.

    Hopefully he can fix or suggest likewise ;)

    For those that read in my earlier post i was using the WP Mail Bank plugin - I have no idea why i was using it or why i installed it :) The QCF plugin does indeed have SMTP built in (when its working) so that WP plugin will get removed soon.

    At present i have left the site with no contact option as its safer than what it was doing before, at least possible users will know there is an issue with emails.
     
    Posted: Dec 6, 2019 By: Davek0974 Member since: Mar 7, 2008
    #9
  10. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    I've tested the plugin using the default settings and it all works. The thank you message displayed I got the email.
     
    Posted: Dec 7, 2019 By: fisicx Member since: Sep 12, 2006
    #10
  11. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Thanks, so i have a problem with my host blocking SMTP ??

    I'll open a ticket
     
    Posted: Dec 7, 2019 By: Davek0974 Member since: Mar 7, 2008
    #11
  12. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Why do you need to use SMTP?

    It works with the default settings.

    PS: I replied to your emails. Did you get them? If not this indicates a problem wit your host.
     
    Posted: Dec 7, 2019 By: fisicx Member since: Sep 12, 2006
    #12
  13. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    As i found before and the reason i started this thread - WP Mail is randomly sporadic - it will work for most of the time but then stop sending OR it will not send to some accounts, Gmail was one offender - SMTP fixed that, for a while.

    My system WAS using WP Mail when i got the irate contacts from customers - they had received the "Thanks" message but then it failed to send ME the actual message, this means the customer never hears back.......
     
    Posted: Dec 7, 2019 By: Davek0974 Member since: Mar 7, 2008
    #13
  14. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    It's your host. Not the plugin
     
    Posted: Dec 7, 2019 By: fisicx Member since: Sep 12, 2006
    #14
  15. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    I'll open a ticket - is there anything wise i could ask them that might help??
     
    Posted: Dec 7, 2019 By: Davek0974 Member since: Mar 7, 2008
    #15
  16. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Yes, just wading through support ticket ;)
     
    Posted: Dec 7, 2019 By: Davek0974 Member since: Mar 7, 2008
    #16
  17. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    Support fixed it :)

    Somehow the password stored in SMTP settings was wrong, no idea how this happened or when but the QCF form is now happily sending via SMTP, thanks for the help Fisicx.

    I have also deleted the SMTP plugin so thats another one gone ;)
     
    Posted: Dec 7, 2019 By: Davek0974 Member since: Mar 7, 2008
    #17
  18. Davek0974

    Davek0974 UKBF Ace Free Member

    2,540 308
    OK, so its not fixed :(

    It seems it works 100% for me and tech support said it was working ok for them, but i've had family testing it today and its failed 100% with the same critical error message.

    Not sure what to try now???
     
    Posted: Dec 8, 2019 By: Davek0974 Member since: Mar 7, 2008
    #18
  19. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Where do you see this critical error?

    It works for me as well - no errors and immediate receipt of the email
     
    Posted: Dec 8, 2019 By: fisicx Member since: Sep 12, 2006
    #19
  20. fisicx

    fisicx It's Major Clanger! Staff Member

    32,360 9,573
    Just looked at your test site - there is no SSL. This can cause problems with Woo.
     
    Posted: Dec 8, 2019 By: fisicx Member since: Sep 12, 2006
    #20